www.suinot.org

Dans le doute, reboot. Si ça rate, reformate ! [ devise Windows ]

Accueil > Linux > openwrt & cubieboard2

openwrt & cubieboard2

samedi 22 août 2020, par Rémi

Mise à jour : 25 septembre 2020

  1. retour depuis le reboot sur la nouvelle version : dans l’ensemble àa marche. Sauf pour le wifi. J’ai des problèmes de stabilité, avec perte du signal. La partie radio à l’air de se mettre en défaut, et donc le wifi. Mais je peux prendre la main par le serveur, et rebooter, et le wifi revient. Pas de notion de durée d’utilisation, et difficile de savoir si cela dépend du taux de données qui a transité. Bref, c’est mieux, en gros, mais la, non... Problème de driver ? L’ancienne version n’avait pas ce souci.

J’ai (enfin) fait la mise à jour de mon openwrt sur le cubiboard 2.
Ce fut plus simple et en même temps plus compliqué que prévu.

Pourquoi plus simple :
*- parce que la version [téléchargé] contient tout (ne pas oublier de décompresser après avoir récupéré). Le bootloader, et le fichier dtd. Pour installer, ce n’est pas compliqué : sur ma machine, la clef usb avec la mini carte sd, est référencée sdd, je copie donc avec dd if=openwrt-19.07.3-sunxi-cortexa7-sun7i-a20-cubieboard2-squashfs-sdcard.img of=/dev/sdd
Vraiment rien de plus simple.

Pourquoi plus compliqué :
*- parce que la doc est pas toujours très explicite, je suis partie sur la première fois ou j’ai installé openwrt (version kamikaze !). Il fallait tout récupérer à la main, formater la carte sd, installer le bootloader, ...

A présent, la clef est prête. Je la place dans le cubi, le branche, je regarde sur minicom comment ça se passe. Tout va bien. Mais pas de prise en main via minicom justement... hummm.

Recherches dans la doc et les forums ....

Encore une fois la méthode a été un peu modifié par rapport à mes souvenirs.
Il faut se connecter sur 192.168.1.1, et mettre de suite le mot de passe root. Ensuite, on peut tenter une connexion par http://192.168.1.1 et on tombe sur l’interface web de gestion.

Pour reprendre la configuration précédente, l’erreur à ne pas faire, c’est de copier les anciens fichiers "juste comme ça". Une grande partie iront sans problème particulier (aux erreurs de copier/coller près) mais certains paramètres, par exemple

/etc/config/wireless
config wifi-device 'radio0'
   option path 'platform/soc@01c00000/1c1c000.usb/usb2/2-1/2-1:1.0'

ont été modifié.
Celui ci m’a posé quelques problèmes. Il a changé de forme, mais l’ancienne fonctionne "un peu" de sorte qu’openwrt n’avait pas de soucis jusqu’à ce que celui ci renouvelle les adresses ip (à priori, c’est la que ça plante). Une fois option path modifiée, je n’ai plus eu de problème.

A présent, j’ai un routeur wifi "tout neuf"